PHP 5.4.14

On April 11th 2013, the PHP group has released PHP 5.4.14.

These releases fix about 10 bugs aswell as upgrading the bundled PCRE library. All users of PHP are encouraged to upgrade to PHP 5.4.14.

The corresponding packages are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures with the following changes. As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.

22 replies on “PHP 5.4.14”

thx for update
but it seems geoip and imagick are not updated

The following packages have unmet dependencies:
php5-geoip : Depends: php5-common (= 5.4.13-1~dotdeb.1) but 5.4.14-1~dotdeb.1 is to be installed

The following packages have unmet dependencies:
php5-imagick : Depends: php5-common (= 5.4.13-1~dotdeb.1) but 5.4.14-1~dotdeb.1 is to be installed

There are definitely migration problems because of the new “mods-available” feature. The old .ini files in conf.d do not get removed, but new symlinks are added to basically provide the same purpose.

Big thank you for this update. It has been working well for me for a while.

Though I went to install php5-intl today and got the following:

php5-intl : Depends: phpapi-20090626
Depends: php5-common (= 5.3.3-7+squeeze14) but 5.4.14-1~dotdeb.1 is to be installed

Any help would be great.


@Guillaume Plessis: Information as follows, if I have missed anything out just ask. Thank you for your help.

Distribution: cat /proc/version returns “Linux version 2.6.32-5-amd64 (Debian 2.6.32-48squeeze1) ([email protected]) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Mon Feb 25 00:26:11 UTC 2013”
Architecture: amd64
PHP version: PHP 5.4.13-1~dotdeb.1 (but want to upgrade to 5.4.14)
deb squeeze main non-free contrib
deb squeeze/updates main non-free contrib
deb squeeze main
deb squeeze he-mh

deb squeeze all
deb-src squeeze all

deb squeeze-php54 all
deb-src squeeze-php54 all

Bug: When trying to install php5-intl via “apt-get install” I get an unmet dependencies error.
The following packages have unmet dependencies:
php5-intl : Depends: phpapi-20090626
Depends: php5-common (= 5.3.3-7+squeeze14) but 5.4.14-1~dotdeb.1 is to be installed

@David Manners : that’s strange. Did you run apt-get update before? (5.3.3-7+squeeze14 has been replaced by 5.3.3-7+squeeze15 on March 5th, that’s why I’m asking)

@Guillaume Plessis: at first I did not, but I have now tried it and the error remains.

apt-cache policy php5-intl:
Installed: (none)
Candidate: 5.3.3-7+squeeze14
Version table:
5.4.14-1~dotdeb.1 0
500 squeeze-php54/all amd64 Packages
5.3.24-1~dotdeb.0 0
500 squeeze/all amd64 Packages
5.3.3-7+squeeze15 0
500 squeeze/updates/main amd64 Packages
5.3.3-7+squeeze14 0
990 squeeze/main amd64 Packages

dpkg -l ‘php*’ | grep ‘^.i’
ii php-pear 5.4.13-1~dotdeb.1 PEAR – PHP Extension and Application Repository
ii php5 5.4.13-1~dotdeb.1 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.4.13-1~dotdeb.1 command-line interpreter for the php5 scripting language
ii php5-common 5.4.13-1~dotdeb.1 Common files for packages built from the php5 source
ii php5-curl 5.4.13-1~dotdeb.1 CURL module for php5
ii php5-gd 5.4.13-1~dotdeb.1 GD module for php5
ii php5-imagick 5.4.13-1~dotdeb.1 imagick module for php5
ii php5-mcrypt 5.4.13-1~dotdeb.1 MCrypt module for php5
ii php5-memcache 5.4.13-1~dotdeb.1 memcache module for php5
ii php5-mysql 5.4.13-1~dotdeb.1 MySQL module for php5

@David Manners : could you please use an APT wrapper, such as dselect or aptitude, to find what prevents the installation of php5-intl=5.4.14-1~dotdeb.1. My guess is that another package needs php5-intl=5.3.3-7+squeeze15

@Guillaume Plessis: So it turns out that I needed to upgrade first to PHP 5.4.14-1~dotdeb.1 before I could install php5-intl.

Now I have done the upgrade everything has installed nicely.

Thank you for your help.

J’ai une tuile lorsque j’essai l’installer php5-fpm:

php5-fpm : Dépend: php5-common (= 5.4.4-14) mais 5.4.14-1~dotdeb.1 devra être installé

## Debian Squeeze sources.list

## FR mirror
deb wheezy main contrib non-free
deb-src wheezy main contrib non-free

## Debian security updates
deb wheezy/updates main contrib non-free
deb-src wheezy/updates main contrib non-free

deb wheezy-backports main

deb wheezy all
deb-src wheezy all

Quelqu’un pour m’aider ?
merci par avance

@Miki : les paquets de PHP 5.4 pour Wheezy ne sont pas encore prêts. En attendant, tu peux ajouter les lignes suivantes dans ton sources.list pour corriger le souci :

deb squeeze-php54 all

Comments are closed.