PHP 5.5.13 for Debian Wheezy

On May 29th 2014, the PHP group has released PHP 5.5.13 :

This release fixes several bugs in PHP 5.5.12, and addresses two CVEs in Fileinfo (CVE-2014-0238 and CVE-2014-0237).

As a consequence, PHP 5.5.13 packages are now available on Dotdeb for Debian 7.5 “Wheezy”, on both amd64 and i386 architectures.

The following modules have been packaged too :

  • apcu 4.0.4
  • gearman 0.8.3
  • geoip 1.0.8
  • imagick 3.1.2
  • memcache 3.0.8
  • memcached 2.2.0
  • mongo 1.5.3
  • pecl_http 1.7.6
  • pinba (master)
  • redis 2.2.5
  • spplus 1.1
  • ssh2 0.12
  • xcache 3.1.0
  • xdebug 2.2.5
  • xhprof 0.9.4

Please note that the default permissions on the FPM Unix socket have been fixed, in a secure way.

Please read the Changelog and the migration guide (be aware of the backward incompatible changes) before upgrading.

And don’t forget: if you find Dotdeb useful, you may want to show your support.

29 replies on “PHP 5.5.13 for Debian Wheezy”

Well it seems libapache2-mod-php5 requires apache2-mpm-prefork but doesn’t accept apache2-mpm-itk which I’m using.
Is there a way to fix this?

If I only want php5 I haven’t reasons to add main repo, because it will try update nginx&mysql… so it’s reasonable to put all dependencies for php 5.5 to wheezy-php55 repo…

I agree with Serg, all dependences should be togather. php55 repo is currently useless also for us as we cannot update PHP from it (we are using itk too). Guillaume, can you so kind and rethink this one more time? Thank you.

After I upgrade to new php version, I stuck on :
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

How to fix it?


After upgrading to “PHP 5.5.13 for Debian Wheezy” the package “libapache2-mod-php5” will be endless upgraded and replaced by itself.

Die folgenden Pakete werden aktualisiert (Upgrade):
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Vorbereitung zum Ersetzen von libapache2-mod-php5 5.5.13-1~dotdeb.1 (durch …/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb) …

It seems that the version number is the problem:
libapache2-mod-php5 5.5.13-1~dotdeb.1 (blank between php5 and 5.5.13)
libapache2-mod-php5_5.5.13-1~dotdeb.1 (underscore between php5 and 5.5.13)

After installing the upgrade, the same package with the same version will be shown for upgrade again and again.

Thanks for your great work!

I’m having the same issue as @Thomas. PHP5_5.5.13-1 is in a constant update loop. I’m running Wheezy.

My md5sum:
75b7ee7f71aea4dc209ce6241d545750 /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb

$ ls -l /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb
-rw-r–r– 1 root root 2904222 Jun 6 11:25 /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb

Aptitude says:
Actions Undo Package Resolver Search Options Views Help
C-T: Menu ?: Help q: Quit u: Update g: Download/Install/Remove Pkgs
Packages libapache2-mod-php5 info
aptitude DL Size: 2,904 kB
iu –\ libapache2-mod-php5 5.5.13-1~dotde 5.5.13-1~dotde
Description: server-side, HTML-embedded scripting language (Apache 2 module)
This package provides the PHP5 module for the Apache 2 webserver (as found in the apache2-mpm-prefork
package). Please note that this package ONLY works with Apache’s prefork or itk MPM, as it is not compiled
thread-safe. The following extensions are built in: bcmath bz2 calendar Core ctype date dba dom ereg exif
fileinfo filter ftp gettext hash iconv json libxml mbstring mhash openssl pcre Phar posix Reflection session
shmop SimpleXML soap sockets SPL standard sysvmsg sysvsem sysvshm tokenizer wddx xml xmlreader xmlwriter zip

PHP (recursive acronym for PHP: Hypertext Preprocessor) is a widely-used open source general-purpose
scripting language that is especially suited for web development and can be embedded into HTML.
Priority: optional
Section: httpd
Maintainer: Guillaume Plessis
Architecture: amd64
Compressed Size: 2,904 k
Uncompressed Size: 9,849 k
Source Package: php5
— Depends (20)
— Suggests (1)
— Recommends (1)
— Conflicts (5)
— Packages which depend on libapache2-mod-php5 (67)
–\ Versions of libapache2-mod-php5 (5)
p 5.4.4-14+deb7u9
p 5.4.4-14+deb7u11
p 5.4.29-1~dotdeb.1
pi 5.5.13-1~dotdeb.1 +9,849 kB (this line is green)
id 5.5.13-1~dotdeb.1 -9,849 kB (this line is magenta)

@Guillaume: The problem exists on three different servers/workstations and apt-get update does not solve the problem.

@Jeff: Thanks for your details.

More details of my machines:

$ cat /proc/version
Linux version 3.2.0-4-amd64 ([email protected]) (gcc version 4.6.3 (Debian 4.6.3-14) ) #1 SMP Debian 3.2.57-3+deb7u2

$ cat /etc/debian_version

$ md5sum /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb
75b7ee7f71aea4dc209ce6241d545750 /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb

$ ls -l /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb
-rw-r–r– 1 root root 2904222 Jun 6 20:25 /var/cache/apt/archives/libapache2-mod-php5_5.5.13-1~dotdeb.1_amd64.deb

(Same md5sum and filesize as posted by Jeff)

@Thomas : sorry, but there was a silent change (= with the same version number, to save some time and bandwidth) on this package to allow its installation with apache2-mpm-itk. Could you make sure that you’re using as mirror, run apt-get clean to clean your cache. The package’s md5sum should be 40c62eddf3d1c743d8afbc581084438f.

If some use apt-cacher-ng (or similiar software) you also have to delete the package from the cache, otherwise you will end up with a checksum mismatch during the upgrade.

when I try to install php fpm using this command:
sudo apt-get install php5-fpm
I get this error:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-fpm : Depends: libonig2 (>= 5.2.0) but it is not installable
Depends: libqdbm14 (>= 1.8.74) but it is not installable

Any help would be appreciated 😀

@Naeem : could you please provide some more details :
– What is your distribution?
– What is your architecture? amd64 or i386?
– Which exact PHP version do you want to use? 5.5, 5.4.x or 5.3.x?
– Which SAPI do you want to use?? mod_php? CGI? FPM? Embed?
– What’s the full content of your /etc/apt/sources.list and /etc/apt/sources.list.d files?
– What is the result of dpkg -l ‘php*’ | grep ‘^.i’ ?

1- Wheezy (7.5)
2- amd64
3- php 5.5
4- FPM, I use Nginx as webserver
deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ – Official amd64 CD Binary-1 20140426-13:37]/ wheezy main

#for new releases

deb wheezy-backports main contrib non-free

# DotDeb
deb wheezy all
deb-src wheezy all

# For PHP 5.5
deb wheezy-php55 all
deb-src wheezy-php55 all

# Main repositories
deb wheezy main
deb-src wheezy main

deb wheezy-updates main
deb-src wheezy-updates main

deb wheezy/updates main
deb-src wheezy/updates main

6- dpkg-query: no packages found matching php*

@Naeem : that’s very strange, you have all the sources.list entries to satisfy the dependencies :
libonig2 is present in Wheezy :
libqdbm14 is also present in Wheezy :
Please be sure to run apt-get update or equivalent to refresh your cache. An you might also want to use a fronted such as dselect or aptitude to know exactly what prevents php5-fpm from being installed.

I’m running latest Debian Wheezy and I’m unable to rebuild your PHP package.
due too most of my libs are installed into /usr/lib/x86_64-linux-gnu instead of /usr/lib. I’ve tried –with-libdir= parametrer but do nothing. Symlink between /usr/lib/x86_64-linux-gnu and /usr/lib is a problem as many libs are involved !

I have the same problem. If I look at the php page source I see my passwords exposed. I currently have apache shutdown until I can resolve this. php is simply not parsing.

I figured out that php’s short tags are disabled by default.

That realization solved the problem for me 😉

Comments are closed.