On December 12th 2013, the PHP group has released PHP 5.5.7. This release fixes some bugs against PHP 5.5.6 and it also includes a fix for CVE-2013-6420 in OpenSSL extension. All users are strongly encouraged to upgrade.
As a consequence, PHP 5.5.7 packages are now available on Dotdeb for Debian 7.0 “Wheezy”, on both amd64 and i386 architectures.
Please read the Changelog and the migration guide (be aware of the backward incompatible changes) before upgrading.
Last but not least, if you find Dotdeb useful, you may want to show your support.
10 replies on “PHP 5.5.7, for Debian 7.0 “Wheezy””
Is not running apache 2.4 (as well as version 5.5.6 dotdeb):
“# service apache2 restart
[FAIL] Restarting web server: apache2 failed!
[warn] The apache2 configtest failed. … (warning).
Output of config test was:
apache2: Syntax error on line 142 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: unixd_config
Action ‘configtest’ failed.”
@Andrey : Dotdeb packages are built for Debian Wheezy or Squeeze, that come with Apache 2.2. It’s no surprise if they don’t work with another major release of Apache. Which distribution/version are you using?
I use Wheeze, but Apache is installed from Jessie.
But if not support it, the questions asked.
Failed to fetch http://packages.dotdeb.org/dists/wheezy-php55/php5/binary-all/php-pear_5.5.6-1~dotdeb.1_all.deb 404 Not Found [IP: 126.96.36.199 80]
Failed to fetch http://packages.dotdeb.org/dists/wheezy-php55/php5/binary-amd64/php5-dev_5.5.6-1~dotdeb.1_amd64.deb 404 Not Found [IP: 188.8.131.52 80]
@Hrach : please run apt-get update (or equivalent) before any further move
I have one problem, i can´t install php-apc
php5-apc : Depends: phpapi-20100525
Depends: php5-common (= 5.4.23-1~dotdeb.1) but 5.5.7-1~dotdeb.1 is to be installed
php5-apcu : Depends: php5-common (= 5.5.6-1~dotdeb.1) but 5.5.7-1~dotdeb.1 is to be installed
Someone to help?
@Jorge : there is no apc for PHP 5.5, it has been replaced by zendopcache (ex zend optimizer, bundled as opcache in php5-common). If you need a user cache, install php5-apcu. And if you upgrade from PHP 5.4, uninstall php5-apc before any further move.
@Guillaume Plessis: php5-apcu worked very well. Thanks for your help.
The problem was a cache for symfony2, usually apc. But works well with apcu.
Please do you now, where I can get newset version of Apache? Now it giv me after ‘aptitude update; aptitude safe-upgrade’ only Apache 2.2.22.
@Guillaume Plessis Thank you for you work, i has updated debian 7 php on 5.5.7, all work perfectly!