MySQL 5.1.58 is available

MySQL 5.1.58 packages are now available on Dotdeb :

  • for Debian 6.0 “Squeeze” and Debian 5.0 “Lenny”
  • for the amd64 and i386 architectures

The corresponding Pinba storage engine has also been rebuilt (Squeeze only).

And, as usual, please read the Changelog of this maintainance release before upgrading.

19 replies on “MySQL 5.1.58 is available”


since the update from 5.1.57 to 5.1.58 w have a big problem. the configured open_files_limit is ignored an set to the default 1024. so we always get a “ERROR 1018 (HY000) at line 1: Can’t read dir of ‘.’ (errno: 24)”

@Guillaume Plessis : What is your guess of MySQL 5.5 availability on Dotdeb? Weeks? Months?

Hello i get an error when i try to install mysql-client-5.1_5.1.58-1~dotdeb.1_amd64.deb

Vorbereitung zum Ersetzen von mysql-client-5.1 5.1.54-1ubuntu4 (durch …/mysql-client-5.1_5.1.58-1~dotdeb.1_amd64.deb) …
Ersatz für mysql-client-5.1 wird entpackt …
dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/mysql-client-5.1_5.1.58-1~dotdeb.1_amd64.deb (–unpack):
Versuch, »/usr/bin/mysql« zu überschreiben, welches auch in Paket mysql-client-core-5.1 5.1.54-1ubuntu4 ist
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
E: Sub-process /usr/bin/dpkg returned an error code (1)

this error came with both mirrors:
deb stable all
deb-src stable all

deb stable all
deb-src stable all

@Gordon Franke : Dotdeb is built for Debian, not for Ubuntu. You may encounter such issues.

Your problem is that the mysql-client-5.1 package from Dotdeb includes the /usr/bin/mysql file that already belongs to mysql-client-core-5.1 from Ubuntu. Be sure to uninstall this last one before installing MySQL packages from Dotdeb.

Before upgrade with the my.cnf provided by the package:

#Nov 8 07:41:15 alienvault mysqld: 111108 7:41:15 [ERROR] /usr/sbin/mysqld: unknown variable ‘lc-messages-dir=/usr/share/mysql’

Can’t install 5.1 from dotdeb any more, please help. I can’t upgrade to 5.5 yet.

# apt-get install vim less mysql-server-5.1 tor polipo
Reading package lists… Done
Building dependency tree
Reading state information… Done
less is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mysql-server-5.1 : Depends: mysql-client-5.1 (>= 5.1.58-1~dotdeb.1) but it is not going to be installed
Depends: libmysqlclient16 (>= 5.1.50-1) but it is not going to be installed
PreDepends: mysql-common (>= 5.1.58-1~dotdeb.1) but it is not going to be installed
E: Broken packages

cat /etc/apt/sources.list
deb squeeze main contrib non-free
deb squeeze-updates main contrib
deb squeeze/updates main contrib
deb stable all
deb squeeze-backports main

Are you planning to fix it? It would really be nice to be able to install dotdeb 5.1 on squeeze. Now it seems impossible. We’re practically stuck with the 1.5 years old release in squeeze.

Comments are closed.