On March 3rd 2016, the PHP group released PHP 5.6.19.
This is a security release in which several security bugs were fixed. All PHP 5.6 users are encouraged to upgrade to this version.
PHP 5.6.19 packages are now available for Debian 7 “Wheezy”, on both amd64 and i386 architectures, in ZTS and non-ZTS (default) flavors, along with the usual PECL extensions.
Bonjour,
Je souhaites savoir si cette version de PHP sur wheezy est compatible avec apache 2.2?
Merci d’avance pour la réponse!
Cordialement,
Noël
Hello!
I can’t install php5-sybase package. I get this: The following packages have unmet dependencies: php5-sybase : Depends: phpapi-20100525 Depends: php5-common (= 5.4.45-1
dotdeb+7.1) but 5.6.19-1dotdeb+7.1 is to be installedIs there anything I can do about it in the ‘proper’ way? Thank you
Hello Guilllaume Plessis,
using aptitude I see this:
aptitude install php5-sybase
The following NEW packages will be installed: apache2-mpm-prefork{a} apache2-utils{a} apache2.2-bin{a} apache2.2-common{a} libapache2-mod-php5filter{ab} libapr1{a} libaprutil1{a} libaprutil1-dbd-sqlite3{a} libaprutil1-ldap{a} php5-sybase{b} The following packages will be REMOVED: libboost-filesystem1.49.0{u} libboost-program-options1.49.0{u} libboost-system1.49.0{u} libboost-thread1.49.0{u} libgearman6{u} libnet-daemon-perl{u} libpcrecpp0{u} libplrpc-perl{u} 0 packages upgraded, 10 newly installed, 8 to remove and 44 not upgraded. Need to get 4,302 kB of archives. After unpacking 13.7 MB will be used. The following packages have unmet dependencies: libapache2-mod-php5filter : Depends: php5-common (= 5.4.45-1
dotdeb+7.1) but 5.6.19-1dotdeb+7.1 is installed. php5-sybase : Depends: php5-common (= 5.4.45-1dotdeb+7.1) but 5.6.19-1dotdeb+7.1 is installed. The following actions will resolve these dependencies:Actually I am using nginx, not sure why it needs apache2 php5filter
Thank you
Hello @Guillaume
well souces.list is quote general:
Dotdeb stuff
deb http://packages.dotdeb.org wheezy all deb-src http://packages.dotdeb.org wheezy all
#deb http://packages.dotdeb.org wheezy-php55 all #deb-src http://packages.dotdeb.org wheezy-php55 all deb http://packages.dotdeb.org wheezy-php56 all deb-src http://packages.dotdeb.org wheezy-php56 all
Java
#deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main #deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main
Debian Backports
#deb http://debian.mirror.vu.lt/debian/ wheezy-backports main contrib non-free
Main packages
deb ftp://debian.mirror.vu.lt/debian/ wheezy main contrib non-free
Testing
#deb ftp://debian.mirror.vu.lt/debian/ sid main contrib non-free
Debian Updates / ex-volatile
deb ftp://debian.mirror.vu.lt/debian/ wheezy-updates main contrib non-free
Debian Security updates
deb ftp://debian.mirror.vu.lt/debian-security/ wheezy/updates main contrib non-free
I have
apt-get updateonce more, and tried installing - results the sameHello,
I have done apt-get update. apt-get upgrade.
And installing this, agains getting this error. Really not sure why… Something must have messed up the repos for me probably :/
Hello,
Thank you very much for all your work with these repositories. I thought I had successfully upgraded a Debian 7.0 installation to use PHP 5.6, but I have been dealing with the following error:
The following packages have unmet dependencies: php5-adodb : Depends: phpapi-20100525
When I try to install the dependency: E: Package ‘phpapi-20100525’ has no installation candidate
Do you have any advice? I wound normally just mess around with this until I understood better, but unfortunately I am forced to work on a production server which makes me very nervous!
Hello Guillaume!
here is the more informationhttps://gist.github.com/huglester/da5e01fa6edbc3e5adf7
But I know that earlier I have added something about java to sources.list for sure.. then removed.
Not sure how to recover from this hell now…
Thank you, Jaroslav
What I don’t understand is why, given this sources.list, the first error message you gave was mentioning “PHP 5.4.45-1~dotdeb+7.1”. Please make sure that you ran apt-get update first.
In doubt, you could remove all PHP-related packages and re-install them from scratch.
Hi,
after running apt-get update, I want to install php-apc, but it depends on phpapi-20100525.
The following packages have unmet dependencies: php-apc : Depends: phpapi-20100525 E: Unable to correct problems, you have held broken packages.
When I then want to install phpapi-20100525, it gives me:
Package phpapi-20100525 is a virtual package provided by: php5-fpm 5.4.44-1
dotdeb+7.1 [Not candidate version] php5-fpm 5.4.45-1dotdeb+7.1 [Not candidate version] php5-cli 5.4.44-1dotdeb+7.1 [Not candidate version] php5-cli 5.4.45-1dotdeb+7.1 [Not candidate version] php5-cgi 5.4.44-1dotdeb+7.1 [Not candidate version] php5-cgi 5.4.45-1dotdeb+7.1 [Not candidate version] libphp5-embed 5.4.44-1dotdeb+7.1 [Not candidate version] libphp5-embed 5.4.45-1dotdeb+7.1 [Not candidate version] libapache2-mod-php5filter 5.4.44-1dotdeb+7.1 [Not candidate version] libapache2-mod-php5filter 5.4.45-1dotdeb+7.1 [Not candidate version] libapache2-mod-php5 5.4.44-1dotdeb+7.1 [Not candidate version] libapache2-mod-php5 5.4.45-1dotdeb+7.1 [Not candidate version]My installed php5 version is 5.6.19 and doesn’t seem to provide phpapi.
dpkg -l | grep php
ii libapache2-mod-php5 5.6.19-1
dotdeb+7.1 amd64 server-side, HTML-embedded scripting language (Apache 2 module) ii php5 5.6.19-1dotdeb+7.1 all server-side, HTML-embedded scripting language (metapackage) [.. etc ..]Is this somehow fixable or to be worked around with, without downgrading php?
thanks in advance,
Remco
Thanks.
I was hopeful, but it didn’t work.
The following packages have unmet dependencies: php5-apc : Depends: phpapi-20100525 Depends: php5-common (= 5.4.45-1
dotdeb+7.1) but 5.6.19-1dotdeb+7.1 is to be installed E: Unable to correct problems, you have held broken packages.