Dotdeb’s packages of Nginx 1.2.4 are now available for Debian 6.0 “Squeeze” (amd64/i386). They fix some minor bugs, please take a look at Nginx’ official Changelog before upgrading.
Please also note that Passenger has been upgraded to the 3.0.17 version.
As usual, if you want to know which module has been included in each Nginx flavor, you just have to look at this document.
Is there a way to add “nginx-lua” after installing “nginx-full”?
I’m not interested in the other bits of the “nginx-extras” package.
I tried installing nginx passenger on debian 6.0.5 amd64 , but i end up with some errors, I am using ruby enterprise edition 1.8.7
root@debian:~# apt-get install nginx-passenger Reading package lists… Done Building dependency tree
Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: nginx-passenger : Depends: ruby-passenger (> 3.0.17) but it is not going to be installed E: Broken packages
root@debian:~# apt-get install ruby-passenger Reading package lists… Done Building dependency tree
Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: ruby-passenger : Depends: libev3 (>= 3.0) but it is not installable Depends: libruby1.8 (>= 1.8.7.302) but it is not installable or libruby1.9.1 (>= 1.9.2.0) but it is not installable Depends: ruby but it is not installable or ruby-interpreter but it is not installable Depends: librack-ruby1.8 but it is not installable or librack-ruby1.9.1 but it is not installable E: Broken packages
@sampath : using Passenger from Dotdeb with another ruby versions than the system’s ones will be painful. If you really want to use ree, install passenger as a gem and run it standalone or with nginx using the passenger-install-nginx-module command.
I’ll think I’ll deprecate nginx-passenger soon, because alternative ways to run rails applications (like unicorn or puma) are much more performant and stable. Sorry.
I believe there’s a problem with nginx’s default config (valid at least for nginx-light).
root /usr/share/nginx/www;
But there’s no such directory and it causes nginx to loop while searching for index.html out of box:
[error] 2003#0: *1 rewrite or internal redirection cycle while internally redirecting to “/index.html”
Changing default root to /usr/share/nginx/html (which actually exists) solves the problem.
@Alex : I had that issue with nginx-full. Could you please report it here : https://github.com/gplessis/dotdeb-nginx/issues
Thank you
Hi. I would like to ask if you could include the http://wiki.nginx.org/HttpSubsModule module in one of the next releases.
Thanks Mark