On April 29th 2016, the PHP group released PHP 5.6.21.
This is a security release. Several security bugs were fixed in this release. All PHP 5.6 users are encouraged to upgrade to this version.
PHP 5.6.21 packages are now available for Debian 7 “Wheezy”, on both amd64 and i386 architectures, in ZTS and non-ZTS (default) flavors, along with the usual PECL extensions.
I cannot install the package mysqlnd because of the priorities… Can you help me?
node4:
# apt-cache policy php5-mysqlnd php5-mysqlnd: Installed: (none) Candidate: 5.4.45-0+deb7u2 Version table: 5.6.21-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.20-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.19-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.18-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.17-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.16-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.15-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.14-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.13-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.12-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.6.11-1dotdeb+7.1 0 500 http://packages.dotdeb.org/ wheezy-php56/all amd64 Packages 5.4.45-0+deb7u2 0 990 http://cdn.debian.net/debian/ wheezy/main amd64 Packages 990 http://security.debian.org/ wheezy/updates/main amd64 PackagesError:
node4:~# apt-get install php5-mysqlnd Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php5-mysqlnd : Depends: phpapi-20100525 Depends: php5-common (= 5.4.45-0+deb7u2) but 5.6.21-1~dotdeb+7.1 is to be installed E: Unable to correct problems, you have held broken packages.
Great, thx.
Package: php5-mysqlnd Pin: release o=packages.dotdeb.org Pin-Priority: 990