On March 20th 2015, the PHP group released PHP 5.5.23.
Several bugs have been fixed as well as CVE-2015-0231, CVE-2015-2305 and CVE-2015-2331. All PHP 5.5 users are encouraged to upgrade to this version.
PHP 5.5.23 packages are now available on Dotdeb for Debian 7 “Wheezy”, on both amd64 and i386 architectures.
The following modules have been packaged too :
- apcu 4.0.7
- gearman 0.8.3
- geoip 1.0.8
- imagick 3.1.2
- memcache 3.0.8
- memcached 2.2.0
- mongo 1.6.5
- pecl_http 1.7.6
- pinba (master)
- redis 2.2.7
- spplus 1.1
- ssh2 0.12
- xcache 3.2.0
- xdebug 2.3.2
- xhprof 0.9.4
Please read the Changelog and the migration guide (be aware of the backward incompatible changes) before upgrading.
The following bug is a real blocker for us. Any chance of a patch?
https://bugs.php.net/bug.php?id=69293
Hi,
I have this issue: https://github.com/duccio/ApnsPHP/issues/84
Is there a way to downgrade to 5.5.22?
Thanks.
I am trying install php5-dev on debian wheezy but get this error:
root@linux:~# apt-get install php5-dev Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php5-dev : Depends: libssl-dev but it is not going to be installed Depends: libtool (>= 2.2) but it is not going to be installed Recommends: dh-php5 but it is not installable E: Unable to correct problems, you have held broken packages. root@linux:~#
Any help would be appreciated.
apt-sources:
deb http://http.debian.net/debian wheezy main contrib non-free deb-src http://http.debian.net/debian wheezy main contrib non-free
deb http://http.debian.net/debian wheezy-updates main contrib non-free deb-src http://http.debian.net/debian wheezy-updates main contrib non-free
deb http://security.debian.org/ wheezy/updates main contrib non-free deb-src http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.us.debian.org/debian wheezy-backports main contrib non-free
deb http://download.webmin.com/download/repository sarge contrib
deb http://packages.dotdeb.org wheezy all deb-src http://packages.dotdeb.org wheezy all deb http://packages.dotdeb.org wheezy-php55 all deb-src http://packages.dotdeb.org wheezy-php55 all
deb http://download.virtualbox.org/virtualbox/debian wheezy contrib
deb http://www.deb-multimedia.org wheezy main non-free deb ftp://ftp.deb-multimedia.org wheezy main non-free
Anybody has issue with PECL installing anything with the new 5.5.23 release? Seems like if you use proxys, you fail to install anything. I had to upgrade squid3 to 3.4 with SSL support to get anything running with channel-update. But i cant install anything do to wrong HTTP/1.1 requests
is this somehow related to https://pecl.php.net/package-changelog.php?package=pecl_http&release=2.4.3 ?
Anything else possible?