On October 2nd 2014, the PHP group released PHP 5.6.1.
Several bugs were fixed in this release. All PHP 5.6 users are encouraged to upgrade to this version.
PHP 5.6.1 packages are now available on Dotdeb for Debian 7.6 “Wheezy”, on both amd64 and i386 architectures.
Please also note these points :
- Regression :
php5-memcachedlacks JSON support - Missing packages : Xdebug and Xhprof are missing for now
- End of support : Spplus won’t be supported anymore. Xcache’s and Pinba’s fates haven’t been decided yet
As a consequence :
- Don’t upgrade yet if you need missing features
- For users upgrading from PHP 5.5, a full migration guide is available, detailing the changes between 5.5 and 5.6.0
- The full list of changes is available in the ChangeLog
- Your feedbacks are always welcome. Just make sure they are useful.
To install PHP 5.6 or to upgrade from previous version just follow the instructions.
Version PHP 5.6.1-1~dotdeb.1 :
1 - I have a same problem for pear and pecl (install or upgrade or upgrade-all) :
[…] could not extract the package.xml file from “/usr/src/php5.6/source/dotdeb-php5/pear-build-download/*.tgz” Download of “…” succeeded, but it is not a valid package archive Error: cannot download “…” Download failed upgrade-all failed […]
2 - I can’t find pecl.so
Thanks.
@Iaina Randrianarivony : sorry for not fixing this in the new release. I’ll upload a new build in a few days.
https://github.com/gplessis/dotdeb-php5/commit/7cea26e780e54d38fa49a9dec0a9b41e1850417a
[PROBLEM SOLVED]
Problem with pear and pecl after upgrade php in the last version :
Problem : […] could not extract the package.xml file from “/usr/src/php5.6/source/dotdeb-php5/pear-build-download/*.tgz” Download of “…” succeeded, but it is not a valid package archive Error: cannot download “…” Download failed upgrade-all failed […]
Solution :
Download Archive_tar and extract it > wget http://download.pear.php.net/package/Archive_Tar-1.3.13.tgz > tar zxvf Archive_Tar-1.3.13.tgz
Copy Tar.php and Archive_Tar.txt in the original destination > cp /Archive_Tar-1.3.13/Archive/Tar.php /usr/share/php/Archive/ > cp /Archive_Tar-1.3.13/docs/Archive_Tar.txt /usr/share/php/doc/Archive_Tar/
Run command :D > pear upgrade-all or > pecl upgrade-all
Work for me ^_^ , no error
I’ve some trouble installing php-apc:
apt-get install php-apc
Reading package lists… Done Building dependency tree
Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php-apc : Depends: phpapi-20100525 E: Unable to correct problems, you have held broken packages.
Also when I try to install the dependency manually:
apt-get install phpapi-20100525
Reading package lists… Done Building dependency tree
Reading state information… Done Package phpapi-20100525 is a virtual package provided by: php5-fpm 5.4.33-1
dotdeb.1 [Not candidate version] php5-cli 5.4.33-1dotdeb.1 [Not candidate version] php5-cgi 5.4.33-1dotdeb.1 [Not candidate version] libphp5-embed 5.4.33-1dotdeb.1 [Not candidate version] libapache2-mod-php5filter 5.4.33-1dotdeb.1 [Not candidate version] libapache2-mod-php5 5.4.33-1dotdeb.1 [Not candidate version] php5-fpm 5.4.4-14+deb7u14 [Not candidate version] php5-cli 5.4.4-14+deb7u14 [Not candidate version] php5-cgi 5.4.4-14+deb7u14 [Not candidate version] libphp5-embed 5.4.4-14+deb7u14 [Not candidate version] libapache2-mod-php5filter 5.4.4-14+deb7u14 [Not candidate version] libapache2-mod-php5 5.4.4-14+deb7u14 [Not candidate version] php5-fpm 5.4.4-14+deb7u11 [Not candidate version] php5-cli 5.4.4-14+deb7u11 [Not candidate version] php5-cgi 5.4.4-14+deb7u11 [Not candidate version] libphp5-embed 5.4.4-14+deb7u11 [Not candidate version] libapache2-mod-php5filter 5.4.4-14+deb7u11 [Not candidate version] libapache2-mod-php5 5.4.4-14+deb7u11 [Not candidate version]E: Package ‘phpapi-20100525’ has no installation candidate
Should php-apc be supported? Any clue why it isn’t working properly?
Thanks in advance!
Please find a fix for xdebug. Debugging in PHP is a pain without it.
thx for answer
greets
Hello,
i upgraded from 5.5 to 5.6 and get the following error:
initctl: Unknown job: php5-fpm
I can’t start php5-fpm with services php5-fpm start:
If i try to start it with /etc/init.d/php5-fpm start nothing happens
I googled for a solution and found this https://github.com/gplessis/dotdeb-php5/issues/45 But that doesn’t work for me… Or maybe iam doing something wrong.
Do you need any more infos? Iam on Debian 7.6.