Zabbix 2.0.7 has been released on July 31st 2013. It fixes known issues of Zabbix 2.0.x and introduces new minor features (take a look at the Zabbix 2.0.7 release notes for more info).
The packages are now available :
- for Debian 7.0 “Wheezy and 6.0 “Squeeze”,
- on both amd64 and i386 architectures.
Should be easy to do, you can check the rules at http://repo.zabbix.com/zabbix/2.0/debian/pool/main/z/zabbix/zabbix_2.0.6-1.debian.tar.gz.
As for Debian main repository this won’t happen any time soon due to https://support.zabbix.com/browse/ZBX-4800
on fresh debian wheezy install i get:
aptitude install zabbix-server-mysql The following NEW packages will be installed: ca-certificates{a} krb5-locales{a} libcurl3-gnutls{a} libgssapi-krb5-2{a} libiksemel3{a} libk5crypto3{a} libkeyutils1{a} libkrb5-3{a} libkrb5support0{a} libldap-2.4-2{a} librtmp0{a} libsasl2-2{a} libsasl2-modules{a} libssh2-1{a} openssl{a} zabbix-server-mysql{b} The following packages are RECOMMENDED but will NOT be installed: mysql-server snmpd 0 packages upgraded, 16 newly installed, 0 to remove and 3 not upgraded. Need to get 5731 kB of archives. After unpacking 9412 kB will be used. The following packages have unmet dependencies: zabbix-server-mysql : Depends: libmysqlclient16 (>= 5.1.21-1) which is a virtual package. Depends: libopenipmi0 but it is not going to be installed. Depends: libsnmp15 (>= 5.4.3~dfsg) but it is not going to be installed. Depends: ucf but it is not going to be installed. Depends: fping but it is not going to be installed. The following actions will resolve these dependencies:
I want to use libmysqlclient18 from 5.5 mysql is it possible at all?
sorry was my mistake.
i had squeeze instead of wheezy.
any chance of removing mysql-server dependency from the zabbix?
i think its not needed at all.
zabbix supports remote mysql configuration.
for example: php5-mysql is not needing mysql-server but its definitely need mysql server somewhere to connect to.
I don’t think so.
Here is what aptitude gives me:
aptitude install zabbix-server-mysql The following NEW packages will be installed: ca-certificates{a} heirloom-mailx{a} krb5-locales{a} libaio1{a} libclass-isa-perl{a} libcurl3-gnutls{a} libdbd-mysql-perl{a} libdbi-perl{a} libgssapi-krb5-2{a} libhtml-template-perl{a} libiksemel3{a} libk5crypto3{a} libkeyutils1{a} libkrb5-3{a} libkrb5support0{a} libldap-2.4-2{a} libnet-daemon-perl{a} libplrpc-perl{a} librtmp0{a} libsasl2-2{a} libsasl2-modules{a} libssh2-1{a} libswitch-perl{a} mysql-client-5.5{a} mysql-server{a} mysql-server-5.5{a} mysql-server-core-5.5{a} openssl{a} perl{a} perl-modules{a} psmisc{a} snmpd{a} zabbix-server-mysql 0 packages upgraded, 33 newly installed, 0 to remove and 3 not upgraded. Need to get 23.9 MB of archives. After unpacking 138 MB will be used. Do you want to continue? [Y/n/?]
@dotdeb user : you can also try apt-get –no-install-recommends install zabbix-server-mysql.
http://manpages.ubuntu.com/manpages/precise/man8/apt-get.8.html
many thanks!
that worked.
what about zabbix-frontend-php?
is it possible to run it on nginx+php5-fpm?
i get this on apt-get install –no-install-recommends zabbix-frontend-php:
The following NEW packages will be installed: apache2-mpm-prefork apache2-utils apache2.2-bin apache2.2-common libapache2-mod-php5 libaprutil1-dbd-sqlite3 libaprutil1-ldap php5 ttf-dejavu-core
Package: zabbix-frontend-php
State: not installed Version: 1:2.0.7-1~dotdeb.0 Priority: optional Section: net Maintainer: Guillaume Plessis Uncompressed Size: 24.0 M Depends: ucf, apache2 | httpd, php5, php5-mysql | php5-mysqlnd | php5-pgsql | php5-sqlite, php5-gd, ttf-dejavu-core Suggests: libapache2-mod-php5 | php5-fpm, php5-pgsql | php5-mysql | php5-mysqlnd Description: network monitoring solution - PHP front-end Zabbix is a server/client network monitoring system with many features. It can be used for:
This package provides a web-browsable front-end to the Zabbix server, which can display graphs of the data collected from clients. Homepage: http://zabbix.com
Can you add nginx and php5-fpm here?
Thanks a lot.
btw, it seems to not possible to build from your source zabbix-php-frontend or zabbix-server-mysql.
source package requires debhelper >= 9 whilst in squeeze it’s 8.0
@dotdeb user : use squeeze-backports
http://packages.debian.org/search?keywords=debhelper
And FYI, if you prefer, you can find Zabbix 2.0.6 in wheezy-backports
sure, i can do that, but i want actually 2.0.7 to use.
dont you think that if you’re claiming support on squeeze, package should be compatible for building too?
i solved this by just copying needed php files to the www docroot, the only disadvantage now is updating, but i will try later your advice.