On june 14th 2012, the PHP group has released PHP 5.4.4, that brings over 30 bug fixes, some of which are security related : A weakness in the DES implementation of crypt and a heap overflow issue in the phar extension. Please also note that the use of php://fd streams is now restricted to the CLI SAPI ( php5-cli).
Packages of PHP 5.4.4 are now available on Dotdeb for Debian 6.0 “Squeeze” on both amd64 and i386 architectures (see the installation instructions).
As usual, please read the ChangeLog before upgrading and be sure to use to the latest packages before reporting any issue.
I was trying to install php5-memcached with squeeze and got following result:
The following packages have unmet dependencies: php5-memcached : Depends: libmemcached9 but it is not installable E: Broken packages
when I checked at debian, this package is only available in sid, hurd-i386.
Can you resolve this?
php5-mysqlnd is not installing:
Unpacking php5-mysqlnd (from …/php5-mysqlnd_5.4.4-2
dotdeb.0_i386.deb) … Processing triggers for php5-fpm … Restarting PHP5 FastCGI Process Manager: php5-fpm. Setting up php5-mysqlnd (5.4.4-2dotdeb.0) … ucfr: Attempt from package php5-mysqlnd to take /etc/php5/mods-available/mysql.ini away from package php5-mysql ucfr: Aborting. dpkg: error processing php5-mysqlnd (–configure): subprocess installed post-installation script returned error exit status 4 Processing triggers for php5-fpm … configured to not write apport reports Restarting PHP5 FastCGI Process Manager: php5-fpm. Errors were encountered while processing: php5-mysqlnd E: Sub-process /usr/bin/dpkg returned an error code (1)@Johny : are the corresponding .ini file present in /etc/php5/conf.d/ with such a content?
extension=gd.so
I just discovered this repository and I’m excited to try out the packages. I want to build and test a current/bleeding edge web server for optimal performance, and to stay ahead of exploits.
I choose Debian because I heard they are literally the only distro that has an Apache 2.4 package at all, which they have in experimental. But I’m not seeing packages anywhere for libapache2-mod-fcgid or libapache2-mod-php5 that will work with Apache 2.4.
Is that something you’d consider adding to your repository?
Likewise, I believe openssl needs to be updated for Apache 2.4.
Also, I have the PHP 5.4 packages installed from SID/Unstable. Since adding this repository, it now tells me that my previously installed packages of php5-imagick php5-memcache and php5-suhosin have unmet dependencies.
How would I switch my PHP packages from SID/Unstable to the ones in this repository?
i try to install memcached : apt-get install php5-memcached
but i found an error : php5-memcached : Dépend: php5-common (= 5.4.4-2~dotdeb.0) mais 5.4.4-2 devra être installé
i try to purge php5-common and re-install, but i got same error… plz help :-(
I’m having an issue installing php5-mysqlnd. I purged php5-mysql and double checked that /etc/php5/mods-available and /etc/php5/conf.d did not contain any mysql .conf files.
Setting up php5-mysqlnd (5.4.4-2~dotdeb.0) … Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini ERROR: /etc/php5/mods-available/mysqlnd.ini does not exist
Here’s the full aptitude output:
Selecting previously deselected package php5-mysqlnd. (Reading database … 39201 files and directories currently installed.) Unpacking php5-mysqlnd (from …/php5-mysqlnd_5.4.4-2
dotdeb.0_amd64.deb) … Processing triggers for php5-fpm … Restarting PHP5 FastCGI Process Manager: php5-fpm. Setting up php5-mysqlnd (5.4.4-2dotdeb.0) … Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini ERROR: /etc/php5/mods-available/mysqlnd.ini does not exist dpkg: error processing php5-mysqlnd (–configure): subprocess installed post-installation script returned error exit status 2 Processing triggers for php5-fpm … configured to not write apport reports Restarting PHP5 FastCGI Process Manager: php5-fpm. Errors were encountered while processing: php5-mysqlnd E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover: Setting up php5-mysqlnd (5.4.4-2~dotdeb.0) … Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini Not replacing deleted config file /etc/php5/mods-available/mysqlnd.ini ERROR: /etc/php5/mods-available/mysqlnd.ini does not exist dpkg: error processing php5-mysqlnd (–configure): subprocess installed post-installation script returned error exit status 2 Processing triggers for php5-fpm … Restarting PHP5 FastCGI Process Manager: php5-fpm. Errors were encountered while processing: php5-mysqlndI found a solution here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=444076
It appears that either php5-mysql didn’t purge correctly, or a previous attempt at installing php5-mysqlnd didn’t purge correctly. To get a proper install, I ran: ucf –purge /etc/php5/mods-available/mysql.ini ucf –purge /etc/php5/mods-available/mysqli.ini ucf –purge /etc/php5/mods-available/pdo_mysql.ini ucf –purge /etc/php5/mods-available/mysqlnd.ini
@Chris @Guillaume Plessis I have the same problem and i’m using debian stable, I think.
The following packages have unmet dependencies: php5-memcache : Depends: php5-common (= 5.3.15-1~dotdeb.0) but 5.4.4-3 is to be installed
Linux 2.6.32-5-amd64 x86_64 GNU/Linux
dotdeb.0 php5-memcache=5.3.15-1dotdeb.0Just to thank you for this post… Went almost like a brieze (pb with xdebug failing to find the module giving an error when updating as the old path to the .so hasn’t been updated when the first upgrade failed).
Thx again!!!!
apt-get install php5-memcached
Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php5-memcached : Depends: libmemcached10 but it is not installable E: Broken packages
Seems like it does not work under Debian 6.0 and php54 repositories apt-get update did not help ?
@Pawel : did you add these two lines in your sources.list?
The first repo contains libmemcached, the second PHP 5.4.
I’m having the same issues. Debian squeeze, and yes, both of the lines are in repo, and I’ve ran apt-get update…
apt-get install php5-memcached Reading package lists… Done Building dependency tree
Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php5-memcached : Depends: libmemcached10 but it is not installable Depends: libmemcachedutil2 but it is not installable E: Broken packages