The packages of MySQL 5.5.22 are now available for Debian 6.0 “Squeeze” on both amd64 and i386 architectures with no major change except bug fixes.
As usual, please read carefully the full Changelogs of MySQL 5.5.21 and MySQL 5.5.22 before upgrading.
Thanx.
I’ve made upgrade from MySQL 5.5.20 to 5.5.22 without any problem.
Hello,
Thanks for all the hard work. I am however encountering an issue after upgrading to this package. I was running 5.5.20 prior to upgrading and had 1 master 2 slaves using semisynchronous replication. After upgrading all was well and is still working on these boxes.
The problem I am running into is that I am trying to add a slave to the group and unfortunately after importing the data and trying to start the slave I am getting errors about duplicate keys or unable to delete record errors. It’s like either the data from mysqldump is not complete, the master is reporting the wrong position, or it’s not importing the data correctly.
I thought this might be a case of some update happening to the master between displaying the log file and dumping the data, so I turned off all the boxes, changed the port on the master, and locked all the tables just to make sure there were no changes going on… but unfortunately this did not work.
Is this a possible bug in 5.5.22?
Thanks again, Westin
@Guillaume - Thanks for the quick response. It actually looks like flush tables isn’t really flushing the tables. I noticed that once I had locked the tables and then did the mysqldump the log pos changed quite dramatically. Using this new log pos everything came up as expected.
Thanks again for all your hard work and helping to keep our systems up to date. It is appreciated.
Westin
hello,
when installed mysql, I met the following errro:
apt-get install libmysqlclient-dev mysql-client-5.5 mysql-server-5.5 mysql-common
Reading package lists… Done Building dependency tree
Reading state information… Done mysql-common is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: mysql-client-5.5 : Depends: libdbi-perl but it is not going to be installed Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed mysql-server-5.5 : Depends: libdbi-perl but it is not going to be installed E: Broken packages
apt-get install libmysqlclient-dev mysql-client-5.5 mysql-server-5.5 mysql-common libdbi-perl libdbd-mysql-perl
Reading package lists… Done Building dependency tree
Reading state information… Done mysql-common is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: libdbd-mysql-perl : Depends: perlapi-5.10.1 libdbi-perl : Depends: perlapi-5.10.1 E: Broken packages
apt-get install libmysqlclient-dev mysql-client-5.5 mysql-server-5.5 mysql-common libdbi-perl libdbd-mysql-perl perlapi-5.10.1
Reading package lists… Done Building dependency tree
Reading state information… Done Package perlapi-5.10.1 is a virtual package provided by: perl-base 5.10.1-17squeeze2 [Not candidate version] perl-base 5.10.1-17squeeze3 [Not candidate version]
E: Package ‘perlapi-5.10.1’ has no installation candidate
apt-get install libmysqlclient-dev mysql-client-5.5 mysql-server-5.5 mysql-common libdbi-perl libdbd-mysql-perl perl-base
Reading package lists… Done Building dependency tree
Reading state information… Done mysql-common is already the newest version. perl-base is already the newest version. Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: libdbd-mysql-perl : Depends: perlapi-5.10.1 libdbi-perl : Depends: perlapi-5.10.1 E: Broken packages
The content of the /etc/apt/sources.list file :
cat /etc/apt/sources.list
deb http://apt.x.netease.com:8660/data/debian/ stable main contrib non-free deb http://apt.x.netease.com:8660/data/debian-security stable/updates main contrib non-free deb http://packages.dotdeb.org stable all deb-src http://packages.dotdeb.org stable all
before i want to say thank you for your job. i had use this repository for my own VPS. But, can i request repo for MongoDB?
thanks
Hello,
Thank you for your hard work and making these updates available.
Are there any plans to update the pinba-mysql-engine package - this seems tied to MySQL 5.1.61-2~dotdeb at the moment - which makes installation of pinba awkward.
David.
Hello, i want to install apt-get install mysql-client-5.1 mysql-server-5.1 on debian . but below error i am getting for dependencies as below
The following packages have unmet dependencies: mysql-client-5.1 : Depends: libdbi-perl but it is not going to be installed Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed Depends: mysql-common (>= 5.1.73-1) but it is not going to be installed Depends: libmysqlclient16 (>= 5.1.73-1) but it is not going to be installed mysql-server-5.1 : Depends: libdbi-perl but it is not going to be installed Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed PreDepends: mysql-common (>= 5.1.73-1) but it is not going to be installed
Can you please help me to come out of it.
source.list as below
deb http://security.debian.org/ wheezy/updates main contrib deb-src http://security.debian.org/ wheezy/updates main contrib
deb http://ftp.de.debian.org/debian squeeze main non-free