Dotdeb packages of Redis for Debian 6.0 “Squeeze” have been updated to version 2.2.10. Here are the release notes.
fernon
hello! I’m sorry that I write here
how can I install php 5.2.17 for debian 6 “Squeeze” ?
Could you please send detailed instructions or publish a separate article on the site. I never found how to do it correctly. I think it will be interesting to many users.
@fernon : installing PHP 5.2.17 is not recommended, this version has no active support yet.
If you still want to install it, add this line in your source.list :
deb http://packages.dotdeb.org lenny all
After an apt-get update, something like “apt-get install php5=5.2.17-0.dotdeb.0” should work.
Or maybe you should download and install the packages manually.
fernon
if install from lenny,i get a problem with mysql
apt-get install -t lenny php5-mysql
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
php5-mysql : Depends: libmysqlclient15off (>= 5.0.51a) but it is not installable
can you do php 5.2.17 specifically for debian 6? because many php scripts are written in an older version of php and wants to work on debian 6. I think many would have you to thank for it!!! installing php 5.2.17 from lenny on debian 6 appear a lot of problems, in contrast to centos 5.6
I won’t maintain an unsupported piece of software such as PHP 5.2.17 for Squeeze. Installing the packages from Lenny is a good (temporary) solution. Sorry.
Antony
excusez, les commentaires étant fermés sur la page php5.3.6 je ne vois pas comment faire autrement…
I’m stuck with php5-fpm_5.3.6-6~dotdeb.0_amd64.deb
/var/lib/dpkg/tmp.ci/postrm: line 23: dpkg-maintscript-helper: command not found
Any way I could delete that package?
And not have
dpkg-maintscript-helper: error: environment variable DPKG_MAINTSCRIPT_NAME is required
hello! I’m sorry that I write here how can I install php 5.2.17 for debian 6 “Squeeze” ?
Could you please send detailed instructions or publish a separate article on the site. I never found how to do it correctly. I think it will be interesting to many users.
@fernon : installing PHP 5.2.17 is not recommended, this version has no active support yet.
If you still want to install it, add this line in your source.list : deb http://packages.dotdeb.org lenny all
After an apt-get update, something like “apt-get install php5=5.2.17-0.dotdeb.0” should work.
Or maybe you should download and install the packages manually.
if install from lenny,i get a problem with mysql
apt-get install -t lenny php5-mysql Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:
The following packages have unmet dependencies: php5-mysql : Depends: libmysqlclient15off (>= 5.0.51a) but it is not installable
can you do php 5.2.17 specifically for debian 6? because many php scripts are written in an older version of php and wants to work on debian 6. I think many would have you to thank for it!!! installing php 5.2.17 from lenny on debian 6 appear a lot of problems, in contrast to centos 5.6
@fernon : download and install libmysqlclient15off manually (http://packages.debian.org/lenny/libmysqlclient15off) to satisfy the dependency or introduce the lenny-related lines in your sources.list.
I won’t maintain an unsupported piece of software such as PHP 5.2.17 for Squeeze. Installing the packages from Lenny is a good (temporary) solution. Sorry.
excusez, les commentaires étant fermés sur la page php5.3.6 je ne vois pas comment faire autrement…
I’m stuck with php5-fpm_5.3.6-6~dotdeb.0_amd64.deb
/var/lib/dpkg/tmp.ci/postrm: line 23: dpkg-maintscript-helper: command not found Any way I could delete that package?
And not have dpkg-maintscript-helper: error: environment variable DPKG_MAINTSCRIPT_NAME is required
Thanks for your help.
@Antony : from /2011/04/09/php-5-3-6-is-available/
“Just downloaded the script from http://debomatic.debian.net/natty/natty/usr/bin/dpkg-maintscript-helper and put it in /usr/bin
A little fussing later and all is well!”
I’ll fix this problem in the upcoming 5.3.7 packages.
Hello,
Why not contributing to debian backports ?